Commit a8dda295 authored by Damien George's avatar Damien George
Browse files

Fix part->port in README.

parent 30a5f853
...@@ -37,7 +37,7 @@ You will also need bash and python (2.7 or 3.3) for the stm port. ...@@ -37,7 +37,7 @@ You will also need bash and python (2.7 or 3.3) for the stm port.
The Unix version The Unix version
---------------- ----------------
The "unix" part requires a standard Unix environment with gcc and GNU make. The "unix" port requires a standard Unix environment with gcc and GNU make.
x86 and x64 architectures are supported (i.e. x86 32- and 64-bit). ARM to x86 and x64 architectures are supported (i.e. x86 32- and 64-bit). ARM to
be confirmed. Porting to other architectures require writing some assembly be confirmed. Porting to other architectures require writing some assembly
code for the exception handling. code for the exception handling.
...@@ -59,7 +59,7 @@ module (recommended, enable in unix/mpconfigport.mk), libffi-dev is required. ...@@ -59,7 +59,7 @@ module (recommended, enable in unix/mpconfigport.mk), libffi-dev is required.
The STM version The STM version
--------------- ---------------
The "stmhal" part requires an ARM compiler, arm-none-eabi-gcc, and associated The "stmhal" port requires an ARM compiler, arm-none-eabi-gcc, and associated
bin-utils. For those using Arch Linux, you need arm-none-eabi-binutils and bin-utils. For those using Arch Linux, you need arm-none-eabi-binutils and
arm-none-eabi-gcc packages from the AUR. Otherwise, try here: arm-none-eabi-gcc packages from the AUR. Otherwise, try here:
https://launchpad.net/gcc-arm-embedded https://launchpad.net/gcc-arm-embedded
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment