Commit 0c2ff0b7 authored by Maxime Perrotin's avatar Maxime Perrotin

Download antlr 3.1.3 when needed to build grammar

parent 40a2fb37
#!/bin/bash
#!/bin/bash -e
echo 'you must download and install antlr_python_runtime-3.1.3.tar.gz:
(from http://pypi.python.org/pypi/antlr_python_runtime/3.1.3 for ex)
......@@ -13,6 +13,18 @@ sudo rm $(cat install.record)
You must also download and unpack antlr-3.1.3.tar.gz
'
if [ ! -d antlr-3.1.3 ]
then
wget http://download.tuxfamily.org/taste/misc/antlr-3.1.3.tar.bz2
tar xvf antlr-3.1.3.tar.bz2
NO_ANTLR=1
fi
export CLASSPATH=$(pwd)/antlr-3.1.3/lib/antlr-3.1.3.jar
java org.antlr.Tool sdl92.g
if [ $NO_ANTLR ]
then
rm -rf antlr-3.1.3
rm antlr-3.1.3.tar.bz2
fi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment