Commit 8137359f authored by jhugues's avatar jhugues
Browse files

* (PolyORB_HI_Ada_Makefile): handle Platform_LINUX32 and

	 Platform_LINUX64 as native platforms;
	 add better error message for unsupported platforms



git-svn-id: https://tecsw.estec.esa.int/svn/taste/trunk/ocarina@3064 129961e7-ef38-4bb5-a8f7-c9a525a55882
parent 5ebc0112
...@@ -162,7 +162,10 @@ package body Ocarina.Backends.PO_HI_Ada is ...@@ -162,7 +162,10 @@ package body Ocarina.Backends.PO_HI_Ada is
-- name. -- name.
case Execution_Platform is case Execution_Platform is
when Platform_Native | Platform_None => when Platform_Native
| Platform_LINUX32
| Platform_LINUX64
| Platform_None =>
Change_If_Empty (String_Ptr (Target_Prefix), ""); Change_If_Empty (String_Ptr (Target_Prefix), "");
Target := new String'("NATIVE"); Target := new String'("NATIVE");
...@@ -186,7 +189,8 @@ package body Ocarina.Backends.PO_HI_Ada is ...@@ -186,7 +189,8 @@ package body Ocarina.Backends.PO_HI_Ada is
null; null;
when others => when others =>
raise Program_Error; raise Program_Error with "Unsupported platform: "
& Execution_Platform'Img;
end case; end case;
if Execution_Platform /= Platform_LEON_RTEMS then if Execution_Platform /= Platform_LEON_RTEMS then
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment