Commit 622c73c8 authored by Maxime Perrotin's avatar Maxime Perrotin

Fix printing help

parent f5e4e410
......@@ -34,6 +34,7 @@ LICENSE: LGPL - see LICENSE file
CHANGELOG:
1.6.4 - Fix printing help with --help
1.6.3 - Fix PI import names in opengeode 2.x.x simulator
1.6.2 - Use mono prefix to call msc2py.exe
1.6.1 - Fix messages that did not appear on the GUI if received too fast
......
......@@ -16,7 +16,7 @@
__author__ = "Maxime Perrotin"
__license__ = "LGPLv3"
__version__ = "1.6.3"
__version__ = "1.6.4"
__url__ = "http://taste.tuxfamily.org"
import sys
......
......@@ -154,7 +154,7 @@ def gui():
msclist_enable = True
#usage = 'usage: gui.py [--udp=IP_Address:in_Port:out_Port]'
version = 'taste auto-gui %s' % (__version__)
version = 'Version ' + __version__
# Set up the logging facilities
log = logging.getLogger("gui")
......@@ -163,7 +163,6 @@ def gui():
log.addHandler(console)
log.info('Starting GUI')
myPrint = MyLogger(log)
sys.stdout = myPrint
# Parse the command line
parser = argparse.ArgumentParser(version=version)
......@@ -187,6 +186,8 @@ def gui():
else:
log.setLevel(logging.INFO)
sys.stdout = myPrint
log.debug('{version} using Python {pyVersion}'.format(
version=version, pyVersion=platform.python_version()))
log.debug('Using interface view (for MSC processing): ' + options.ivpath)
......
......@@ -12,9 +12,9 @@
The SingleValueEditor widget can also be embedded in another Qt application
This version needs ASN.1 version 3.x.x
This version needs ASN1SCC V4
Copyright (c) 2012-2017 European Space Agency
Copyright (c) 2012-2018 European Space Agency
Designed and implemented by Maxime Perrotin
......@@ -60,7 +60,7 @@ except ImportError:
try:
UI_FILE = ':/singleEditor.ui'
from asn1_value_editor import asn1Editor
from asn1_value_editor import asn1Editor, __version__
from vn import valueNotationToCTypes
except ImportError:
logger.error('ASN1 Value Editor import error')
......@@ -309,7 +309,7 @@ def main():
signal.signal(signal.SIGINT, signal.SIG_DFL)
usage = 'usage: asn1_value_editor -a file.asn -t type [-d default value]'
version = 'ASN.1 Value Editor'
version = 'ASN.1 Value Editor version ' + __version__
logger.info('Starting ASN.1 Value Editor')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment